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Presentation overview

• Download Sentinel-1 and Sentinel-2 data

• SNAP download

• Exercise 1 – Sentinel-1 preprocessing and data fusion (SNAP)

• Sen2Cor download

• Exercise 2 – Sentinel-2 atmospheric correction and NDVI index 
(Sen2Cor, SNAP)
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Download Sentinel-1 and Sentinel-2 data
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https://scihub.copernicus.eu/

Open Hub

https://scihub.copernicus.eu/


Download Sentinel-1 and Sentinel-2 data
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Download Sentinel-1 and Sentinel-2 data
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Download Sentinel-1 and Sentinel-2 data
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Download Sentinel-1 and Sentinel-2 data
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SNAP: Sentinel Application Platform
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http://step.esa.int/main/download/
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Exercise 1 – Sentinel-1 preprocessing and 
data fusion (SNAP)
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-> File
-> Import
-> SAR Sensors
-> SENTINEL-1

Navigate to first of 
three Sentinel-1 
data folder, select 
„manifest.safe” and 
confirm with
„Import Product”
button.
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Exercise 1 – Sentinel-1 preprocessing and 
data fusion (SNAP)
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In „Product Exporer” 
panel navigate to 
„Bands” and double-
click on 
„Intensity_VV” to 
visulize the data 
with VV polarization.

1

1

In „Colour 
Manipulation” panel 
click on „Switch to 
logarithmic display” 
and use black, grey 
and white sliders to 
stretch image 
histogram.

2

2

Data navigation panel
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Select Sentinel-1 
image from drop-
down list of open 
layers.

Exercise 1 – Sentinel-1 preprocessing and 
data fusion (SNAP)
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Click on „Graph 
Builder” icon to 
open empty graph.

1 1

Right-click on the 
empty canvas and 
navigate to „Subset” 
tool (Add -> Raster -
> Geometric -> 
Subset). A new TAB 
appears below the 
canvas.

3
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Exercise 1 – Sentinel-1 preprocessing and 
data fusion (SNAP)
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In the same way as „Subset” tool add 
„Speckle-Filter”, „Calibration” and „Terrain-
Correction” tools to the canvas.

o Speckle-Filter
• Add -> Radar -> Speckle Filtering -> 

Speckle-Filter
o Calibration

• Add -> Radar -> Radiometric -> 
Calibration

o Terrain-Correction
• Add -> Radar -> Geometric -> Terrain 

Correction -> Terrain-Correction

Right-click on the canvas and click „Connect 
Graph” or connect tools manually by 
dragging arrows - starting from the right 
border of each element
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Exercise 1 – Sentinel-1 preprocessing and 
data fusion (SNAP)
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Open „Subset” tab and define in pixel 
coordinates upper left corner (X, Y) and size 
(Width, height) of the desired subset. If 
„Source Bands:” window is empty simple 
switch between different tabs to refresh the 
view. Select two Intensity layers only (with 
Ctrl button).

Open „Speckle-Filter” tab and define Filter 
(e.g. Gamma Map) and Filter Size X and Y 
(e.g. 7). Select two Intensity layers only (with 
Ctrl).
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Exercise 1 – Sentinel-1 preprocessing and 
data fusion (SNAP)
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Leave „Calibration” tab options without 
changing anything.

In „Terrain-Correction” tab change “Image 
Resampling Method” to 
„NEAREST_NEIGHBOUR” and “Map 
Projection” to desired projection.
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Exercise 1 – Sentinel-1 preprocessing and 
data fusion (SNAP)
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Open „Write” tab and define processed file 
name (you can leave it default), file format 
(BEAM-DIMAP as default), and saving 
location.

Click on „Save” button to save created Graph 
and hit „Run” to execute workflow. The 
processed image will appear in „Product 
Explorer” window.

Repeat the procedure to generate 
preprocessed subsets for two other data 
sets from different acquisition dates:
• import Sentinel-1 data into SNAP
• use „Graph Builder” to load and execute 

previously saved workflow.
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Exercise 1 – Sentinel-1 preprocessing and 
data fusion (SNAP)
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Generated Sentinel-1 
subsets for three 
different acquisition 
dates.

Navigate to:
-> Radar
-> Coregistration
-> Stack Tools
-> Create Stack
to open stack 
creation tool.
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Exercise 1 – Sentinel-1 preprocessing and 
data fusion (SNAP)
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In „1-ProductSet-Reader” tab 
use plus symbol to open „Add 
Product” dialog. Navigate to and 
select three Sentinel-1 subsets 
(with Ctrl button). Press „ok” 
button to add files to the list. 
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Exercise 1 – Sentinel-1 preprocessing and 
data fusion (SNAP)
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In „2-CreateStack” tab change „Resampling 
Type:” to „NEAREST_NEIGHBOUR” and „Output 
Extents:” to „Minimum”. 

Go to „3-Write” tab and modify (or leave default 
values) product name and output directory. 
Execute tool by pressing „Run” button. 
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Exercise 1 – Sentinel-1 preprocessing and 
data fusion (SNAP)
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Right-click on the 
newly created stack 
and select „Open 
RGB Image Window”.

From drop-down list 
select VV bands 
(three different 
dates) for red, green 
and blue and press 
„OK” to create RGB 
composition.
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Exercise 1 – Sentinel-1 preprocessing and 
data fusion (SNAP)
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A new “Image 
Window” will appear 
with RGB 
composition.

If needed, adjust 
histogram stretching 
for each layer (red, 
green, blue)
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Exercise 1 – Sentinel-1 preprocessing and 
data fusion (SNAP)
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Make sure that the 
stacked image is 
selected in „Product 
Explorer” window.

Navigate to:
-> File
-> Export
-> GeoTIFF
to open „SNAP –
Export Product” tool.

Specify file name and 
location and press 
„Export Product” 
button.
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Sen2Cor: Sentinel-2 Level 2A Atmospheric 
Correction Processor
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http://step.esa.int/main/third-party-plugins-2/sen2cor/
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Exercise 2 – Sentinel-2 atmospheric 
correction and NDVI index (sen2cor, SNAP)
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Sentinel-2 MSI – Level-2A Prototype Processor Installation and User Manual

CHAPTER 3 – CONFIGURATION AND INSTALLATION (page 31)

• Setting up the Runtime Environment (Anaconda Upgrade/Installation)

o http://continuum.io/downloads

• Sen2Cor Installation

o In the command line utility navigate to the sen2cor-2.3.1 folder, type 

“python setup.py install” and follow the instructions. The setup will 

install the Sen2Cor application and all its dependencies under the 

Anaconda python distribution. 
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Exercise 2 – Sentinel-2 atmospheric 
correction and NDVI index (sen2cor, SNAP)
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• Sen2Cor installation script will use internet connection to download all needed packages.

• User will be asked to press „y” and „Enter” to finish the configuration of environment settings and 

confirm location of sen2cor home directory (which will store e.g. sen2cor configuration file).
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Exercise 2 – Sentinel-2 atmospheric 
correction and NDVI index (sen2cor, SNAP)
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• Use „L2A_PROCESS --help” command to 

display help screen with possible 

options.
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Exercise 2 – Sentinel-2 atmospheric 
correction and NDVI index (sen2cor, SNAP)
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In case of environment variables error (on Windows OS) use following commands to set them correctly:

• SET SEN2COR_HOME=C:\Anaconda2\Lib\site-packages\sen2cor-2.3.1-py2.7.egg\sen2cor

• SET SEN2COR_BIN=C:\Anaconda2\Lib\site-packages\sen2cor-2.3.1-py2.7.egg\sen2cor

If needed adjust both paths to point to the sen2cor folder within Anaconda installation folder.
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Exercise 2 – Sentinel-2 atmospheric 
correction and NDVI index (sen2cor, SNAP)
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• To include DEM data in data correction go to the sen2cor home folder (usually in user’s Documents 

folder, e.g.  „C:\Users\<user-name>\Documents\sen2cor”) and in the „cfg” folder open L2A_GIPP.xml 

file with appropriate editor (like Notepad++).

• In the line with „DEM_Directory” tags change „NONE” to any other name (e.g. „DEM”).
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Exercise 2 – Sentinel-2 atmospheric 
correction and NDVI index (sen2cor, SNAP)
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To start data processing use the following command:

L2A_PROCESS <unzipped image data folder path> <optional parameters>

e.g. 

„L2A_PROCESS D:\S2A_MSIL1C_20170329T095021_N0204_R079_T33TYN_20170329T095024.SAFE

--resolution 10”

S2A_MSIL1C_20170329T095021_N0204_R079_T33TYN_20170329T095024.SAFE

S2A_MSIL2A_20170329T095021_N0204_R079_T33TYN_20170329T095024.SAFE

INPUT FOLDER:

OUTPUT FOLDER:
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Exercise 2 – Sentinel-2 atmospheric 
correction and NDVI index (sen2cor, SNAP)
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In SNAP navigate to:
-> File
-> Import
-> Optical Sensors
-> Sentinel-2
-> S2-MSI-L2A

Navigate to 
processed Sentinel-2 
main data folder, 
select
„MTD_MSIL2A.xml” 
file and use „Import 
Product”.

Training course on the use of satellite products for drought monitoring and agro-meteorological applications.
24-28 April 2017,  Venue, OSMZ HQ Budapest (Hungary)



Exercise 2 – Sentinel-2 atmospheric 
correction and NDVI index (sen2cor, SNAP)
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In „Product Explorer” 
window right-click on 
the newly added data 
and select „Open 
RGB Image Window” 
tool.

In „Select RGB-Image 
Channels” window 
select „B4” band as 
red, „B3” as Green 
and „B2” as Blue to 
create „Natural 
Colors” composition. 
Confirm with „OK”.

A new „Image 
Window” will appear.
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Exercise 2 – Sentinel-2 atmospheric 
correction and NDVI index (sen2cor, SNAP)
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If needed, 
manipulate with 
sliders for Red, Green 
and Blue bands in the 
„Colour 
Manipulation” panel
to strech the
histogram.
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Exercise 2 – Sentinel-2 atmospheric 
correction and NDVI index (sen2cor, SNAP)
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From menu „Raster” 
select „Band 
Maths...”.

In „Band Maths” 
dialog define name 
(e.g. „NDVI”) and 
select „Edit 
Expression...” button.

In „Band Maths 
Expression Editor” 
define expression as: 
„(B8 – B4)/(B8 + B4)” 
and press „OK”.

Confirm with „OK” in 
„Band Maths” 
window.
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Exercise 2 – Sentinel-2 atmospheric 
correction and NDVI index (sen2cor, SNAP)
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A new „Image 
Window” with 
calculated NDVI in 
grey scale will 
appear.

Switch to „Pixel Info” 
tab to inspect NDVI 
values updated from 
the current cursor 
position.
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Exercise 2 – Sentinel-2 atmospheric 
correction and NDVI index (sen2cor, SNAP)
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In “Colour
Manipulation” panel 
switch to “Table” 
view and set red, 
yellow and green 
colors in “Colour” 
column.

Go to “Sliders” view 
and adjust histogram 
to improve clarity of 
the data.
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Exercise 2 – Sentinel-2 atmospheric 
correction and NDVI index (sen2cor, SNAP)
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In menu “Window” 
select “Tile 
Horizontally”.

In “Navigation” tab 
make sure that both 
synchronize views 
and cursor positions 
buttons are selected.
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Exercise 2 – Sentinel-2 atmospheric 
correction and NDVI index (sen2cor, SNAP)
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Use on-screen 
navigation buttons to 
inspect the data. 
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Thank you for your attention.
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